Cursul 1. Notiuni fundamentale privind utilizarea calculatorului 
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1) Scopuri:

2) Introducerea de noţiuni fundamentale:  informatică, informaţie, bit, byte, calculator
3) Prezentarea componentelor unui sistem de calcul
4) Procesorul de documente Microsoft Word
Termenul de informatică este sinonim pentru: ştiinţa calculului, ştiinţa calculatoarelor, ingineria calculatoarelor, tehnologia informaţiei şi a comunicării. Aceste definiţii pot fi extinse astfel:
Informatica cuprinde totalitatea cunoştinţelor asupra calculatorului şi a calculului.
Informatica se ocupă cu:

· studiul proceselor algoritmice care descriu şi transformă informaţia;

·  proiectarea, implementarea şi aplicarea acestora.
Calculatorul este util atunci când lucrăm cu informaţia ce poate fi


Bit-ul (binary digit- cifră binară, adică una din cifrele 0 sau 1) constituie unitatea elementară de informaţie.

Byte-ul (sau octetul, adică o succesiune de opt biţi)  reprezintă unitatea de măsură pentru capacitatea de memorare(cantitatea de informaţie). Un byte se notează cu B iar multiplii acestuia se folosesc pentru a exprima diferite cantităţi de informaţie: 
1 KB (KiloByte)=1024B=210B

1 MB (MegaByte)=1024KB=220B

1 GB (GigaByte)=1024MB=230B

1 TB (TeraByte)=1024GB=240B

1 PB (PetaByte)= 1024TB=250B

1 EB (ExaByte)= 1024PB=260B

Când vorbim de calculator, ne gândim la un ansamblu bine organizat de circute electronice şi informaţii. Componentele fizice ale calculatorului alcătuiesc hardware- ul, iar mulţimea de programe şi informaţii existente în calculator constituie software- ul.

În schema de mai jos sunt evidenţiate componentele unui calculator

Unitatea centrală

· Procesorul- nucleul functional(“creierul”) al calculatorului se mai numeşte şi CPU (Central Processing Unit) adică unitate centrală de prelucrare(are rolul de a prelucra date). El poate fi considerat elementul cel mai important al calculatorului deoarece:
·  este destinat coordonării tuturor operaţiilor ce se efectuează;
· influențează în mod direct performanța PC-ul.
Procesorul execută operaţii:
a) aritmetico- logice(adunări, scăderi, înmulțiri, împărțiri, operațiile algebrei boolene, ce lucrează cu numerele binare 0 și 1), realizate de Unitatea artitmetico-logică (UAL) a procesorului;
b) de comandă și control, realizate de Unitatea de comandă și control(UCC).
Principala caracteristică a sa, viteza de lucru, este exprimată ca frecvenţă (MHz sau GHz=1000MHz) şi reprezintă numărul de operaţii pe care le poate executa într-o secundă.
Memoria

Există 2 categorii de memorii:
1) internă
Procesorul interpretează comenzile unui program şi le execută folosind datele corespunzătoare care se află în memoria internă. Aceasta se împarte în:
a) ROM (Read- Only Memory- memorie numai pentru citire) 
· are capacitate mică de stocare;

· la întreruperea alimentării cu energie, informația din ea nu se pierde;

· conţine un program BIOS (Basic Input Output System) care se execută la pornirea calculatorului şi are grijă ca toate elementele componente ale calculatorului să funcţioneze împreună la pornire; 
· utilizatorul nu o poate modifica, acesta având accesul numai la citire;

· principalul avantaj al memoriei ROM este remanenţa, adică informaţia din ea rămâne memorată şi după întreruperea alimentării.
b)  RAM ( Random Access Memory- memorie cu acces aleator)
· folosită de utilizator pentru derularea lucrărilor sale(este destinată stocării datelor, programelor într-o sesiune de lucru), ce permite accesul atât la citire cât şi la scriere;
· conţinutul său se pierde la oprirea calculatorului (este o memorie volatilă); se recomandă ca utilizatorul să salveze periodic datele cu care lucrează; 
· are capacitate mare de stocare.

Cu cât avem mai mult RAM în calculator (măsurat în megabytes, în general fiind multipli de 8 sau 16MB) cu atât se vor îmbunătăţi performanţele calculatorului.

c) memoria cache

· este un mediu de stocare temporare de mare viteză;
· se interpune între procesor și RAM;
· reține rapid datele furnizate de procesor și le oferă memoriei RAM.
Datorită faptului că memoria RAM a unui calculator  este limitată şi volatilă este necesară utilizarea unor dispozitive de memorare externă, destinate păstrării pe termen lung a unor cantităţi semnificative de date.
2) externă
· este formată din diferite dispozitive de stocare, ce rețin informația pe termen lung;
· principalele memorii externe sunt: 
a) hard disk-ul (principalul dispozitiv de stocare externă) are o capacitate mare de stocare.
· poate fi intern și extern;

· informațiile din HD pot fi citite, modificate, șterse;
· HD poate fi partiționat și formatat;

· activitatea unui hard- disk este semnalizată prin aprinderea unui led, aflat pe panoul central al unităţii centrale.
b) discheta are dimensiunea de 3.5 inchi (1 inch=2.54 cm) şi o capacitate de 1.44MB; are dezavantajul unei capacităţi reduse şi a unei viteze de lucru mică. 
c) CD-ul are capacitate mare de 700MB, echivalentul a 486 de dischete de 1.44MB; 
d) DVD-ul, 
e) memoria stick. 
Placa de bază este un circuit situat în unitatea centrală, ce permite integrarea componentelor calculatorului.
Plăci de extensie
Placa de reţea are rolul de a intermedia comunicaţia între unitatea centrală a fiecărui calculator dintr-o reţea de calculatoare şi cablurile de reţea. Vitezele de comunicaţie sunt ridicate: 10MB, 100MB, 1GB. 
Placă de modem, al cărei rol este de a adapta comunicaţia dintre calculator şi linia telefonică. 
Periferice.

1. Extensiile multimedia

1.1. CD-urile(CompactDisk-urile) intră în categoria memoriilor externe. Cele mai frecvente CD-uri sunt cele numite CD- ROM( Compact Disk Read Only Memory), care permit doar citirea de informaţie, nu şi scrierea. În ultimul timp s-au răspândit unităţile destinate scrierii de CD- uri, ce pot fi: 

a) CD- R (CD-Recordable)- un disc ce permite scrierea de către utilizator, o singură dată.

b) CD- RW (CD-ReWritable)- un disc ce poate fi scris/ rescris de mai multe ori.

1.2. DVD-urile(Digital Video Disk-urile) sunt CD-uri cu  densitate de înregistrare crescută, având capacitatea tipică de 4.7- 17.08 GB, care le permite să înregistreze  ore întregi de 
informaţie muzicală/ video. DVD-urile se pot întâlni sub următoarele tipuri:

-read-only: DVD-ROM;

-write-once: DVD-R;

-rewritable: DVD-RW, DWD-RW, DVD-RAM;

1.3. Memoria stick  (memorie flash) este o memorie externă, de dimensiuni reduse care se conectează la portul USB (Universal Serial Bus) al calculatorului.
1.4. Placa de sunet împreună cu boxele constituie o cale de ieşire pe care calculatorul o va folosi să ne transmită informaţia sonoră. 
1.5. Microfonul se conecteaza precum difuzoarele la placa de sunet si are rolul in inregistrarea si digitizarea sunetelor cu ajutorul calculatorului.
1.6. Placa video este interfața dintre monitor și procesor, ce are rolul de a afișa imaginea pe monitor. Are: memorie proprie(memorie video) și procesor propriu(GPU- Graphics Processing Unit). Poate fi nu numai dedicată ci și integrată în placa de bază(performanțele sunt reduse în acest caz).
1.7. Creionul optic este un dispozitiv asemănător cu un creion, dar care are la vârf un senzor optic.

1.8. Ecranul tactil (touchscreen) permite introducerea comenzilor prin atingerea directă a obiectelor de pe ecran, cu degetul sau cu un creion special.

1.9. Light pen (Creionul luminos) se utilizeaza pentru desenare pe un ecran special sau pentru selectarea obiectelor de pe ecran. 

1.10. Tableta  este un calculator portabil.
2. Imprimanta este utilizată pentru tipărirea documentelor de pe calculator. După modul în care imaginea documentului este transpusă pe hârtie, există trei tipuri clasice de imprimante: matriceală, cu jet de cerneală, cu laser.
3. Scaner-ul  este un aparat folosit la introducerea în calculator a imaginilor existente pe suport extern (fotografii, hărţi planuri, desene tehnice).
Acea parte de software destinată funcţionării calculatorului se numeşte software de sistem, în timp ce programele destinate să-l ajute pe utilizator la desfăşurarea diverselor activităţi umane intră în categoria software-ului de aplicaţii.

SOFTWARE DE SISTEM
1. Sistemul de operare reprezintă partea de software care asigură exploatarea şi gestionarea resurselor fizice ( hardware) şi informaţionale ( software) disponibile în sistem. Sistemul de operare Windows, în toate versiunile sale: Windows 95, Windows 98, Windows Me, Windows NT, Windows 2000, Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows 8, Windows 10  este cel mai răspândit sistem de operare. 

Informaţiile de pe disc sunt organizate în fişiere şi directoare. Fişierul reprezintă un cumul finit de informaţii. Operaţiile pe care le putem face cu fişiere sunt:

· crearea fişierelor (se întâmplă ori de câte ori salvăm pe disc un document nou);

· modificarea  conţinutului fişierelor ( numită editare sau  actualizare);

· redenumirea fisierului;

· copierea sau mutarea fişierului într-o altă locaţie a  memoriei externe, adică în alt director;

· ştergerea fişierului ( dispariţia informaţiilor conţinute ).

Un director poate conţine (în număr nelimitat) pe lângă fişiere şi subdirectoare, adică directoare subordonate. În acelaşi director nu pot exista două fişiere sau subdirectoare având nume identice. Operaţiile posbile cu directoare:

· crearea de directoare;

·  redenumirea directoarelor;

· copierea/ mutarea directoarelor, care înseamnă copierea/ mutarea în alt director, a întregului conţinut de fişiere şi subdirectoare;

· ştergerea directoarelor ( presupune pierderea conţinutului de fişiere şi subdirectoare);
2. Programe utilitare

a) My Computer este un program utilitar al Windows-ului, prin care vom administra resursele informaţionale (programe, fişiere, directoare). În fereastra sa, resursele informaţionale ale calculatorului apar sub formă de icon-uri. Atunci când se emite un dublu-click pe un icon de “folder”, acesta devine director curent, iar fereastra programului va afişa conţinutul său infomaţional(fişiere şi eventual, subdirectoare). În fereastra My Computer, vom putea alege unul dintre tipurile de afişare a conţinutului unui folder, punctând în meniu View una dintre opţiunile: Thumbnails, Tiles, Icons, List, Details. Lista detaliată (Details) are cea mai mare valoare informaţională, afişând numele, tipul mărimea, data şi ora ultimei actualizări, atributele pentru fiecare dintre fişiere/ subdirectoarele conţinute în directorul curent.

b) Windows Explorer este şi el un program utilitar, foarte asemănător cu My Computer, folosibil la gestionarea fişierelor şi directoarelor, numai că, datorită prezenţei panoului suplimentar din partea stângă are facilitatea copierii/mutării prin drag-and–drop între panouri: se punctează fişierul/ directorul dintr-un panou (uzual cel din dreapta şi se trage cu mouse-ul până ce se ajunge deasupra folderului spre care se face copierea/mutarea). Distincţia între copiere şi mutare se face apăsând tasta Ctrl.
Se poate lansa în execuţie în mai multe moduri: 

· Start->All Programs->Accessories->Windows Explorer;

· o cale rapidă de acces la Windows Explorer se poate asigura plasând o pictogramă shortcut pe desktop.
c) Control Panel este aplicaţia pe care o folosim pentru a extinde sau modifica funcţionalitatea sistemului de calcul(deci a ansamblului hardware+software). 

d) Programe antivirus care:

· detectează şi stopează încercările viruşilor de a pătrunde în sistem,
· identifică fişierele afectate şi recuperează programele afectate.

Viruşii sunt programe care ajung în calculator fie prin fişiere provenind din surse “infestate”, fie prin mesaje e-mail.
Dintre programele antivirus menţionăm: Avira AntiVir Personal, Norton Antivirus, McAfee, Bitdefender, Eset-Nod32, F-Secure Antivirus, Norton Antivirus, Kaspersky Antivirus, AVG AntiVirus.
e) Programe de arhivare-dezarhivare. Prin arhivarea fişierelor se ajunge la un spaţiu necesar de stocare mai redus decât pentru fişierele în forma naturală. Cele mai reprezentative programe sunt ARJ, RAR, WINRAR, WINZIP (furnizează arhive în două formate: RAR şi ZIP) dezarhivarea este procesul invers, prin care se extrag dintr-o arhivă fişierele iniţiale. 
SOFTWARE DE APLICAŢII
1. Procesoarele de documente sunt programe specializate care dispun de comenzi prin care se controlează caracteristici referitoare la:

· încadrarea în pagină (paginarea);

· evidenţierea sau estomparea unor porţiuni de text(font, mărime, stil de scriere, diferite tipuri de aliniere: Left, Center, Right, Justify);

· alte formatări;

· organizarea în tabele, coloane;

· inserţii de imagini sau de grafică (fotografii, ecuaţii matematice, histograme,etc); ş.a
Dintre procesoarele de documente ne vom referi la Microsoft Word.
Implicit, tastatura folosită este cea englezească, marcată prin simbolurile En, în partea dreaptă a barei de taskuri. Pentru ca indicatorul de tastatură să fie vizibil în taskbar, se foloseşte Start->Control Panel->Regional and Language Options-> Languages->Details->Language Bar->Show the Language bar on the desktop. Trecerea la tastatura românească se poate face fie:

· folosind combinaţia de taste indicată în fereastra afişată cu butonul Key Settings (se foloseşte Start->Control Panel->Regional and Language Options-> Languages->Details->Language Bar-> Key Settings);
· cu un click pe indicatorul de tastatură din taskbar, urmat de alegerea dorită.
Deschiderea unui document Word nou: File->New, deschiderea unui document existent: File>Open, închiderea unui document: File->Close, salvarea documentelor: File->Save sau Save as. 
În fereastra Save as, în câmpul Save as type pot fi parcurse într-o listă derulantă formatele de fișiere ce se pot obţine din Word în afara opţiunii prestabilite Word Document (fişiere cu extensia .doc); opţiunea Save to Web Page permite salvarea documentului într-un format publicabil în World Wide Web.
La salvare, documentele pot fi protejate cu parole: File->Save As->Tools->Security Options, Password to open sau Password to modify. În aceste câmpuri se introduce parola care poate conţine până la 15 litere, cifre şi simboluri. După selectarea butonului OK al ferestrei Save va fi afişată caseta de dialog Confirm Password care solicită reintroducerea parolei. După protejarea prin parolă a conţinutului unui fişier, la deschiderea acestuia va fi afişată o casetă de dialog Password unde trebuie testată parola.
a) Paginarea (adică încadrarea documentului într-o pagină virtuală, care va corespunde paginii fizice în situaţia în care se urmăreşte paginarea) se realizează automat, de către procesorul de documente. Prin opţiunile din caseta de dialog referitoare la paginare (Microsoft Word: File
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 Page Setup),  vom putea controla:

· dimensiunile paginii (fie dintr-o listă de dimensiuni standardizate, corelată cu posibilităţile imprimantei destinaţie, fie explicit prin valorile lăţimii şi lungimii);

· aşezarea paginii ( pe verticală- “ portret”; pe orizontală- “ landscape”);

· marginile paginii (distanţele sus- “top”, jos- “bottom”, stânga- “left”, dreapta- “right” dintre marginile paginii fizice şi marginile paginii logice, în care se încadrează textul documentului). Pentru ca aceste dimensiuni să fie în cm (în loc de inchi) se selectează Tools
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Options
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General
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Measurement units.
· când se bifează Mirror margins din Multiple pages, atunci la tipărirea documentului pe ambele feţe ale unei pagini, marginea din stânga a unei feţe devine margine dreaptă pe verso.
Un text informativ plasat în partea de sus a fiecărei pagini se numeşte antet (header), iar dacă se află în partea de jos- subsol(footer). Pentru a crea un antet se selectează View->Header and Footer. Vor fi afişate caseta Header(încadrată într-un dreptunghi punctat) şi bara de instrumente Header and Footer. Crearea antetului se încheie prin apăsarea butonului Close. Crearea unui subsol se face în mod asemănător; comutarea între antet şi subsol se face cu butonul Switch Between Header and Footer din bara de instrumente Header and Footer.
Selectând comanda Different first page din pagina Layout (File
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 Page Setup) putem insera pe prima pagină a unui document a unui antet sau a unui subsol diferit de cel din corpul documentului.
În plus este posibilă configurarea unor anteturi unor anteturi şi subsoluri diferite pentru paginile cu numere pare şi impare dacă bifăm opţiunea Different odd and even.
Pentru a plasa o notă de subsol într-un document se folosesc comenzile Insert
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Reference
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Footnote.
b) În afara  formatărilor elementare (font, mărime, stil, aliniere), se pot realiza formatări de genul:

· stiluri deosebite(din meniul Format
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Font): superscript (pentru scrierea sub formă de exponent), subscript (pentru scrierea sub formă de indice), etc,

· culoare pentru text/scris şi/sau fundal(din meniul Format
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Font),
· aliniere cu indentare(din meniul Format
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Paragraph): un deplasament(de la marginea stângă sau cea dreaptă) impus unui paragraf de text(cu sau fără tratarea specială a deplasamentului pentru primul rând); paragraful este porţiunea de text cuprinsă între două Enter-uri;
· utilizarea tabulatoarelor pentru alinierea paragrafelor: Format->Tabs
· spaţierea paragrafelor ţine seama următoarele trei tipuri de spaţieri: spaţiul liber de dinaintea primei linii a paragrafului (Before), spaţiul liber de după ultima linie a paragrafului (After), spaţiul intern, dintre liniile unui paragraf (Spacing). Ajustarea acestor spaţii se realizează din meniul Format
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Paragraph, pagina Indents and Spacing;  distanţa pe verticală dintre rânduri şi paragrafe poate fi: spaţiere la un rând, la un rând şi jumătate, la două rânduri, etc;
· listele cu marcatori sau numerotate se pot insera din meniul Format
[image: image12.wmf]®

Bullets and Numbering. Paginile Bulleted şi Numbered oferă diferite modele de marcatori şi numerotări pentru liste. Cu butonul Customize se poate stabili o schemă proprie pentru marcare sau numerotare.
· numerotarea automată a paginilor şi înscrierea numărului de pagină: Insert
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Page Numbers, urmată de alegerea poziţiei numărului (Position- Top of page(Header), Bottom of page(Footer)) şi a alinierii acestuia (Alignement- Left, Center, Right, Inside, Outside).
· ruperea paginilor (Insert
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Break
[image: image15.wmf]®

Page Break): când dorim să trecem la o nouă pagină fără să o fi umplut pe cea anterioară.

c) Organizarea textului pe coloane (Format
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Columns
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Apply to:) se poate referi la întregul document sau doar la o casetă de text sau la o celulă de tabel, selectând corespunzător obiectul la care se aplică. Esenţială este controlarea numărului de coloane pe care se va desfăşura textul respectiv.

d) Lucrul cu tabele se bazează pe o serie de operaţii:

· inserarea unui tabel nou (Table
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Insert Table);

· ştergerea unui tabel (Table
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Delete Table);

· inserarea unei coloane noi sau a unui rând nou (Table
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Insert Column/ Row );

· ştergerea coloanei curente sau a rândului curent(Table
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Delete Column/Row );

· modificarea tabelului(Table
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 Table Properties).
Tabelele pot beneficia de facilităţi speciale: divizarea celulei curente în mai multe celule (Table
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Split Cells), respectiv conectarea (fuzionarea) celulelor selectate prin care rezultă o celulă mai mare (Table
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Merge Cells)

Chenarele (Format
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Borders and Shading) cu care înconjurăm (complet sau parţial) tabelele  pot fi construite folosind diverse tipuri de linie, grosimi şi culori. Din pagina Borders se aleg chenarele iar din pagina Shading, nuanţele de fundal.
e) Inserarea unei imagini, stocată dintr-un fişier, într-un document text se realizează alegând Insert
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Picture
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From File.

f) Casetele de text sunt nişte cadre similare celor de imgine, ce se pot plasa oriunde în document şi în interiorul cărora se poate introduce text.
g) Crearea de elemente grafice( Insert
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Picture
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AutoShapes) construirea de elemente grafice simple(linii, cercuri, etc.) în cadrul documentului.
h) Realizarea desenelor este posibilă alegând Insert
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Object
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Microsoft Word Picture.
i) Pentru scrierea relaţiilor aritmetice, logice şi matematice, selectăm Insert
[image: image32.wmf]®

Object
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Microsoft Equation 3.0 sau apăsăm butonul Equation Editor (
[image: image34.wmf]a

) din bara standard. Pentru a aduce  acest buton din meniuri, selectăm Tools
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Customize
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Commands
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Insert apoi căutăm simbolul corepunzător inserării de ecuaţii şi îl tragem cu mouse-ul în bara de instrumente în locul dorit.
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